Debugging#

If you are having trouble with a Zap, this is the place to start. Even if you end up contacting Zapier support it is extremely important to provide context with regards to this debugging documentation so Zapier support can help you quickly without needing lots of back-and-forth emails.

This guide will walk you through identifying common problems that might have gone wrong setting up or running your Zap.

Have you been able to finish your Zap and enable it? No Yes

No#

Check if your Accounts are connected and working in the trigger and action steps . Read more.

Working

Are any required options in your trigger step filled in? Read more.

Filters

Are you using Placeholders in the action template? Read more.

Placeholders

Having trouble loading sample data? Read more

Missing Data Modal

Trouble sending data to a Service? Check out our service-specific documentation.

Yes#

You have turned your Zap On but something is wrong with it. If you can't Trigger your Zap, even though it is On, try these steps:

  • Go into your Service (like Evernote, Salesforce, etc.) and create a new item

  • Go to your Zapier Dashboard and refresh the page

  • Wait about 60 seconds to make sure the Service API reflects the new item

  • Click "Run" next the Zap in question.

Run

  • If you see "Found 0 items", continue

Zero Items

Did you expect Zapier to sync old items already inside your Service? Zapier only syncs new items going forward. Learn more.

  • Click "Edit" and go to the "Test this step" option of your final action.

Step 6

  • Click on "Create and Continue" to test the step, or if you've already tested this zap. click on "Re-test (app) to get another (record)".

Modal

  • If you've already tested this zap, you'll need to go to the "Test this step" option of the trigger app, then click on "Re-test (app) to get another (record)" before testing the action step.

Re-test

  • Re-testing should pull up the most recent record you created in your trigger app.

  • If you are able to find it, then you probably just need to be a little more patient waiting for your Zap to run in the background (or try copying your Zap from the dashboard and deleting the old one to recreate it if you suspect there are problems).

  • If you don't find it, then there might be a mis-understanding about what data Zapier can actually see for a specific trigger or set of Filters, check out service-specific documentation for more nuances.

  • If you're still having trouble, contact us and let us know which steps you followed and what behavior you saw. This will help Zapier support track down the problem quickly.

↑ Was this documentation useful? Yes No (Suggest Edits)
Get Help